Friday, April 11, 2008

Tip of the day: Sony Rolly Motion Editor installation on English OS

Well, It looks like Rolly isn't popular enough here in States, so the only kind of forum posts I found recommended using a Japanese XP in VMware. Which is fine, except I've got no Japanese XP. After changing system locale failed to affect installer's behavior, next idea was to install a MUI. (Un?)fortunately for me and my remaining diskspace, Japanese MUI for x64 Vista SP1 failed to install, and I had to resort to other ideas. Such as: Tried to decrypt the setup.inx and decompile it with SID And figured that installer wants GetSystemDefaultUILanguage to return 0x411 (Japanese LCID) Step-by step instructions: 1. Run installer under debugger ntsd setup.exe in ntsd console, type:
sxi av a GetSystemDefaultUILanguage mov eax,411 ret g
2. Click next-next-..finish. Update: Batch file for lazy ones. Copy Motion Editor directory to the local disk, place this file inside and run it. Additional software: Rolly needs SonicStage in addition for Motion Editor. Fortunately for all non-Japanese speakers out there, there is an English version of that here. PS. You may also want to install 'support for East Asian languages' in Control Panel/Regional & Language Settings to prevent Japanese characters looking like boxes.

18 comments:

alijen said...

hi, i have tried it on czech windows with no luck....
when starting motion editor, error appears "Unknown error."(so typical for windows ;)) It's in japanese, but friend translated it:)... Do you know what could be the problem?

alijen said...
This comment has been removed by the author.
Juan Pablo said...

just got a Japanese rolly and Ive been trying to get the motion editor to work in american Vista business....however, cant get ur file to work...hopefully I can get more help on the matter....

msft.guy said...

@alijen: Did you install SonicStage? I have no idea how to troubleshoot the issue aside from trying to reinstall both Sonic Stage and Motion Editor. You could also try installing it on other computer and see if it helps..
@Juan Pablo: Could you provide me with more details on what goes wrong (or leave your contact info)? Batch file should create a log file on the desktop - can you paste it along with your observations on what happens when you run the batch file? Thanks.

Terry said...

same problem as juan pablo, i installed the debugger, ur file doesnt seem to work.

Setup started
22/06/2008
12:32 PM
Home dir at C:\Users\Terry\Desktop\Motion Editor\.
ERROR: Debugging Tools for Windows not installed.
Please go to http://www.microsoft.com/whdc/devtools/debugging/installx86.mspx to install.

msft.guy said...

@Terry:
The batch file could not find the file
"c:\Program Files\Debugging Tools for Windows\ntsd.exe"
Make sure the file is there, if not, install Debugging tools (32-bit) from here
http://msdl.microsoft.com/download/symbols/debuggers/dbg_x86_6.9.3.113.msi
to "c:\Program Files\Debugging Tools for Windows"
If you're on a 64-bit OS, you should install 32-bit Debugging Tools to
C:\Program Files (x86)\Debugging Tools for Windows\
If your Windows drive is not C:, then replace C: with your Windowss drive letter.

Terry said...

problem solved i had a (x86) on my folder name.

laptop battery said...
This comment has been removed by a blog administrator.
FunInTheSun said...

Thanks to your EXCELLENT blog/knowledge the Rolly a Japanese friend gave me today works on my windows XP laptop.

BUT, no luck with getting the software to install on my other machines which is running under Vista. Sonic Stage installs no worries, and the batch file appears to work (changed the compatibility mode etc), but Motion Editor eventually comes up with "cannot install wrong language" about half way through the process.

Any advise you could give about getting the Rolly software to work on non-Japanese Vista would be greatly appreciated (once again thanks for the XP version).

Bye

Cormac said...

Thanks for the help, I was struggling all day with the installer. I installed everything onto a portable hard-drive using an old XP laptop, and everything works fine now on my new Vista one.

123 said...

could u send the batch file to me donckyu@hotmail.com

msft.guy said...

@123: Sorry, I've already deleted the local file :-(
You can try using the manual steps though..

Hanna K. said...

Hi. I'm a girl. I had not heard about Windows Debugger until I read your post.

I've head japanese Rolly since last christmas now and I was hoping that by now an english version of motion editor would show up. No such luck that's why i looked at your info.

Problem is that I am clueless. I can open ntsd.exe and I get a black screen with commands on it. Am I supposed to just type in it? Or do something else? Please help. You're my only hope for a working Rolly this Christmas! :)
Thanks a lot

Louie Ishii said...

Same problem as Hanna here..

I got the Debugger tool up and running but have no idea how to use it?

Could anyone plz write a step-by-step for dummies ;) on how to add the "motion editor" setup.exe in NTSD and how to write the commands? So I can get some moves into my Rolly ;)

Thanks in advanced!

Rory said...

I have the debugger and run ntsd.exe but then what. Any more detailed info/instructions would be much appreciated. Maybe batch file might be easier for me. How can I get it now you have taken it off? And what would be the detailed instructions? Thanks so much for all your help. Really appreciate it.

Rory said...

I have the debugger and run ntsd.exe but then what. Any more detailed info/instructions would be much appreciated. Maybe batch file might be easier for me. How can I get it now you have taken it off? And what would be the detailed instructions? Thanks so much for all your help. Really appreciate it.

HeZoR said...

Broken link, could you upload the file again?

Also the command line parameters are incorrect, i get an error that "'sxi' is not recognized as an internal or external command, operable program or batch file."

Also, after installation, how can you use it without a proper language file? I use v1.0 that comes with mine.

HeZoR said...

Loaded dbghelp extension DLL
The call to LoadLibrary(ext) failed with error 2.
Please check your debugger configuration and/or network access
...
*** ERROR: Symbol file could not be found. Defaulted to export symbols for ntdll.dll - ntdll!DbgBreakPoint:
7c90120e cc int 3
0:000> sxi av a GetSystemDefaultUILanguage mov eax,411 ret g
^ Extra character error in 'sxi av a GetSystemDefaultUILanguage mov eax,411 ret g'
0:000> sxi GetSystemDefaultUILanguage mov eax,411 ret g

Then a window pops up:

Symbolic Debugger for Windows 2000

Symbolic Debugger for Windows 2000 has encountered a problem and needs to close. We are sorry for the inconvenience.

And the report is:
Error signature
EventType: BEX P1:ntsd.exe P2:5.1.2600.0 P3: 3b7d848c
P4: dbghelp.dll P5: 5.1.2600.5512 P6: 4802a0b2 P7: 0001295d
P8: c0000409 P9: 00000000

I rest my case!